Autor Tema: Terra Cresta - No arranca  (Leído 6161 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Marcos75

  • Socio
  • ****
  • Mensajes: 3046
  • Arcadero de los 80s
Re:Terra Cresta - No arranca
« Respuesta #60 en: 09 de Junio de 2014, a las 19:36 horas »
He estado mirando el fuente de MAME, y podría ser que la PROM esa que hay justo en la zona que dices que has mirado, al lado de las 4 EPROMs de sprites, sea la paleta específica de sprites, con lo cual esa zona que has mirado es interesante.

Llegados a este punto yo iría ampliando la zona de "búsqueda", tratando de ver si hay alguna salida en alta impedancia, o fija, cuando debería estar pulsando. Sin los esquemáticos, es el único recurso que tenemos.

Un saludo.


ricky2001

  • Moderador 2
  • **
  • Mensajes: 1446
  • Arcade Adicto
Re:Terra Cresta - No arranca
« Respuesta #61 en: 10 de Junio de 2014, a las 14:04 horas »
Yo usé una vez los esquemas del Mag max, no son iguales pero se tiran un aire, aunque recuerdo que no tenían muy buena calidad.

Saludos

Marcos75

  • Socio
  • ****
  • Mensajes: 3046
  • Arcadero de los 80s
Re:Terra Cresta - No arranca
« Respuesta #62 en: 10 de Junio de 2014, a las 14:32 horas »
¡Qué bueno! No sabía que existían esos esquemáticos... Edcross, puedes ver en la última página, justo por el centro, la a parte de la derecha del todo, una PROM (7052). Solamente hay una, mientras que el Terra Cresta tiene dos, pero te puede servir de pista.

Dado que el error se te produce en las dos líneas que forman los sprites, yo descartaría todos los integrados "duplicados" que te encuentres en el camino. Es decir, me centraría en las zonas donde las señales van o llegan de un único punto.

Por ejemplo, de A0 a A3 de la PROM llegan de dos 153s distintos, así que los descartaría. Pero por ejemplo de A4 a A8 llegan de un único 377, con lo que lo revisaría. También revisaría las dos o tres 74LS20 que ves por ahí.

Un saludo.