CONSULTAS TÉCNICAS (Arcados, reparaciones y servicio técnico) > Placas Arcade

POCKET GAL - Sin sonido [SOLUCIONADO]

<< < (2/2)

Rockman:
Marcos, has probado de desensamblar el juego en Mame y ver lo primero que hace el juego? Quizá te da alguna pista.

Saludos.

Marcos75:
No, no lo he hecho. Pero la teoría dice que, en cuanto el código retorne de la primera interrupción, la CPU tratará de recuperar el PC de la la pila.

He comprobado A0 y, efectivamente, antes de quedarse fijo, el bus de direcciones tiene actividad durante un instante. De haberme dado cuenta de ese detalle antes, quizá no hubiera ido tan a saco "arrancando la CPU", y hubiera hecho alguna prueba también con la RAM...

Un saludo.

pirilipi:
Qué tal a todos. Revivo este hilo porque tengo una duda de principiante.
Estoy revisando una exciting hours que anda bien pero sin sonido.por las salidas analógicas de los dos ay-3-8910 no hay sonidos
Tengo otra placa idéntica , boot también, así que me ayuda a comparar.
Un cpu 6502 , dos roms, y una ram conforman el sistema. Ya cambié la ram y todo sigue igual. A saber:
Tengo reset y reloj en los tres ( cpu y dos ay3)
En la cpu hay actividad en el bus de datos y de direcciones. Pero la línea int está fija en alto. En la placa buena pulsa.
Además la línea r/w está fija ( siempre está en r)
A veces pareciera que se escuchan las voces pero muy muy distorsionadas..
Mi gran duda es:
Cómo puede haber actividad en los dos buses si el cpu solo está leyendo?
Tal vez está en un bucle ?
Corte la pata rw y la levanté para ver si alguien la estaba atando pero el osciloscipio
Me muestra lo mismo. Siempre en alto.
Eso significaría que el cpu está muerto?
Alguien me explica que está pasando?
Saludos

Navegación

[0] Índice de Mensajes

[*] Página Anterior

Ir a la versión completa