Autor Tema: Base NEO-GEO MVS MV 1FZ cuadros y basura gráfica semiestática.[SOLUCIONADO]  (Leído 2545 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Characa

  • Con experiencia
  • ***
  • Mensajes: 906
Como ya comenté en el hilo de Necesidad de mantenimiento de nuestras placas, abro éste para debatir sobre la avería que presenta mi base NEO-GEO MV 1FZ.

Resumo un poco el problema:

La base, tanto con cartucho como sin el, es más, con o sin BIOS, hace el mismo síntoma, a saber: cuadros de colores, caracteres mezclados y de vez en cuando, parpadeos y alguna línea vertical, vamos, algo inconexo y sin mostrar patrón alguno de comportamiento.

Los Clocks son correctos, pulsan direcciones y datos de ambas CPUs, pero solo mirado un poco por encima, pues el tema de los customs me supera y estaba a punto de comprarme otra base; Ricky opina que habría que darle una oportunidad, con lo que lo he pensado mejor y a ver si entre todos los compis "activos" podemos hacer algo por ella.

Elnaib también me ha remitido a un enlace sobre los test de las MVS, pero al no aparecer nada coherente en pantalla, doy por supuesto que hay algún custom de gestión averiado o incluso la misma BIOS como comenté en el otro hilo.

He mirado posibles pistas corroídas sin éxito (después de una buena limpieza) no se calienta prácticamente ningún chip de un modo sospechoso, con la prueba de la radio parece que esté ejecutando un bucle.

Evidentemente debajo de los customs y los pasamuros cercanos a la batería no puedo acceder y sería tontería hacer la faena de desoldar los chips para verlo.

Ante la imposibilidad de grabar una nueva BIOS por probar lo más fácil, veré si puedo hacerme con otra base para comparar, pues como ya he comentado, la empleo especialmente como carta de ajuste y prueba de cartuchos.

Continuará...
« última modificación: 13 de Enero de 2017, a las 22:02 horas por elnaib »

ID4

  • Con experiencia
  • ***
  • Mensajes: 347
Re:Base NEO-GEO MVS MV 1FZ cuadros y basura gráfica semiestática.
« Respuesta #1 en: 10 de Enero de 2017, a las 14:58 horas »
Buenas

Yo tengo una base 1FZ que le viene a pasar algo similar, y otra 1F que tiene el famoso Z80 Error.

¿Puedes hacer una foto de lo que sale en pantalla cuando la conectas?

¡Saludos!

ID4

elnaib

  • Administrator
  • *****
  • Mensajes: 1040
  • Plegando el espacio
Re:Base NEO-GEO MVS MV 1FZ cuadros y basura gráfica semiestática.
« Respuesta #2 en: 10 de Enero de 2017, a las 15:22 horas »
Hola,

Characa aunque muestre basura en pantalla la diagnostic bios se salta el test de hardware y te indica el problema. Si me das una dirección te puedo enviar una diagnostic bios.

Un saludo

Characa

  • Con experiencia
  • ***
  • Mensajes: 906
Re:Base NEO-GEO MVS MV 1FZ cuadros y basura gráfica semiestática.
« Respuesta #3 en: 10 de Enero de 2017, a las 16:32 horas »
Buenas

Yo tengo una base 1FZ que le viene a pasar algo similar, y otra 1F que tiene el famoso Z80 Error.

¿Puedes hacer una foto de lo que sale en pantalla cuando la conectas?

¡Saludos!

ID4

Hola ID4

Me aparece algo muy parecido a ésto: https://k61.kn3.net/A/D/D/3/D/1/CEE.jpg

Elnaib tienes MP.

Saludos.

ISTRALE

  • Con experiencia
  • ***
  • Mensajes: 498
Re:Base NEO-GEO MVS MV 1FZ cuadros y basura gráfica semiestática.
« Respuesta #4 en: 10 de Enero de 2017, a las 16:37 horas »
Hola characa, has bajado todo los dip switchs para forzar a la base a hacer el test work ram....
Supongo que si y sin exito, no es asi?

Lei en el otro hilo que a veces te daba una pantalla verde, eso sucede a veces con el error del caledario, has mirado el cristal pequeño que hay en la zona de la backup ram, el ls32 y el chip nec 4990?? creo que era así, hablo de memoria...

Cuando hay error de calendario no suele ser basura en la pantalla, pero a mi en concreto una base me fallaba asi y era ese error.

Por cierto si le metes una unibios, a ser posible las version mas actual que puedas, tambien te canta algun error o incluso sale adelante obviando el fallo que tiene, a veces es algo de las ram de respaldo y va bien y otras me ha pasado de tener una video ram mala e iniciar sin sprites.

Yo probaria una unibios y lo que dice elnaib, el diagnostic bios, que suele ayudar mucho.
Saludos.
« última modificación: 10 de Enero de 2017, a las 16:46 horas por ISTRALE »

Characa

  • Con experiencia
  • ***
  • Mensajes: 906
Re:Base NEO-GEO MVS MV 1FZ cuadros y basura gráfica semiestática.
« Respuesta #5 en: 10 de Enero de 2017, a las 17:01 horas »
Esto es lo que aparece en mi caso, como se puede ver es prácticamente igual a la del enlace.



Y de ahí no sale.

Un saludo.

Pd: Istrale, he probado todo lo probable, lo que mencionas también, los customs y yo, no nos llevamos bien :-\



« última modificación: 10 de Enero de 2017, a las 17:08 horas por Characa »

ricky2001

  • Moderador 2
  • **
  • Mensajes: 1446
  • Arcade Adicto
Re:Base NEO-GEO MVS MV 1FZ cuadros y basura gráfica semiestática.
« Respuesta #6 en: 11 de Enero de 2017, a las 01:12 horas »
uff vaya fallo , si el reset lo hace bien no parece nada bueno, ¿has probado también finalmente con la diagnostic bios?

Saludos

Porgadora

  • Con experiencia
  • ***
  • Mensajes: 395
Re:Base NEO-GEO MVS MV 1FZ cuadros y basura gráfica semiestática.
« Respuesta #7 en: 11 de Enero de 2017, a las 12:06 horas »
Creo que en el otro hilo que abrió, respondió que no tenía grabador de chips de 16 bits, para poder grabar las BIOS y probar.
¿Has mirado esto, por si puede ayudar?

 www.aumap.org/foro/index.php?topic=1327.15
« última modificación: 11 de Enero de 2017, a las 12:07 horas por Porgadora »

ricky2001

  • Moderador 2
  • **
  • Mensajes: 1446
  • Arcade Adicto
Re:Base NEO-GEO MVS MV 1FZ cuadros y basura gráfica semiestática.
« Respuesta #8 en: 11 de Enero de 2017, a las 22:35 horas »
No, ese caso era completamente diferente, la placa funcionaba perfecta lo único que no mostraba eran los textos de la Bios y el crosshatch, con lo cual no se podían cambiar los ajustes ni nada, esta no arranca.

Saludos

Porgadora

  • Con experiencia
  • ***
  • Mensajes: 395
Re:Base NEO-GEO MVS MV 1FZ cuadros y basura gráfica semiestática.
« Respuesta #9 en: 11 de Enero de 2017, a las 23:33 horas »
Y meterse entre pecho y espalda una web en inglés que habla sobre esa bios y los posibles problemas de la base Neo-Geo, puede ser un buen tute.
No obstante, te la paso por si te ayuda, ya que habla de componentes (pocos) que pueden fallar y que la diagnostic bios encuentra:
http://smkdan.eludevisibility.org/neo/diag/

Characa

  • Con experiencia
  • ***
  • Mensajes: 906
Re:Base NEO-GEO MVS MV 1FZ cuadros y basura gráfica semiestática.
« Respuesta #10 en: 12 de Enero de 2017, a las 09:53 horas »
uff vaya fallo , si el reset lo hace bien no parece nada bueno, ¿has probado también finalmente con la diagnostic bios?

Saludos

En efecto, los reset los efectúa bien, no sé si será del todo normal pero cuando enciendo la base, tanto el pin RESET del Z80 como el del 68K, pulsan tres o cuatro veces y finalmente quedan en nivel alto.

Sobre la BIOS de diagnóstico, aún no la he podido probar, probablemente pille otra base y comparar su BIOS, pues dudo si quitando la susodicha, aparezcan los defectos que muestro en la foto (cuadros y caracteres inconexos) pues esa BIOS alberga el programa principal supongo, digo supongo pues no tengo medios de comprobar este tipo de ROMs.

¿Has mirado esto, por si puede ayudar?

 www.aumap.org/foro/index.php?topic=1327.15

Porgadora gracias por la info, aunque ya he visto que la avería de mi base no tiene mucho que ver con lo que indica, no acaba de arrancar y se queda como en un bucle.

Un saludo.

« última modificación: 14 de Enero de 2017, a las 08:46 horas por Characa »

Characa

  • Con experiencia
  • ***
  • Mensajes: 906
Re:Base NEO-GEO MVS MV 1FZ cuadros y basura gráfica semiestática.
« Respuesta #11 en: 12 de Enero de 2017, a las 12:15 horas »
Bueno, comento novedades.

Gracias a la ROM de diagnósticos, he podido comprobar que la base tiene un fallo en:



Y de ahí no pasa, no deja hacer nada más.

Entiendo que tiene alguna WRAM (Work RAM) dañada de los bits bajos (lower) o alguna pista corroída.

Tocará ver que chip o chips son los causantes del error y su ubicación.

Saludos.


ISTRALE

  • Con experiencia
  • ***
  • Mensajes: 498
Re:Base NEO-GEO MVS MV 1FZ cuadros y basura gráfica semiestática.
« Respuesta #12 en: 12 de Enero de 2017, a las 12:47 horas »
RAM UNWRITABLE

A RAM seems to output the same data regardless of what is (attempted to be) written to it. The RAM /WE trace or circuit that generates it is suspect.

WRAM UNRITABLE

NEO-C1 WWL (93) → 62256 /WE (27) (lower only)
NEO-C1 WWU (7) → 62256 /WE (27) (upper only)

Mira characa esto es lo que dice la misma pagina de la herramienta de diagnostico sobre tu error.
Saludos.

Characa

  • Con experiencia
  • ***
  • Mensajes: 906
Re:Base NEO-GEO MVS MV 1FZ cuadros y basura gráfica semiestática.
« Respuesta #13 en: 12 de Enero de 2017, a las 17:14 horas »
En efecto, una pista cortada, que a la vista y con lupa parecen perfectas, pero ha sido puentearla y aparecer otro error, el famoso Z80 ERROR, jodida batería!! y eso que está bien.

Cojonudo!!! tengo localizadas un par de pistas en alta impedancia pero pasan por debajo de algunos chips, si hubiera esquema... con lo que creo que ahora sí que sí, (y si no me frenáis) voy a pillar otra base.

Un saludo.


elnaib

  • Administrator
  • *****
  • Mensajes: 1040
  • Plegando el espacio
Re:Base NEO-GEO MVS MV 1FZ cuadros y basura gráfica semiestática.
« Respuesta #14 en: 12 de Enero de 2017, a las 19:11 horas »
Hola,

El error z80 es el más jodido porque puede ser debido a muchas cosas, condensadores, el propio z80, el sm1, el yamaha, una pista corroida, bufffffffffff.

Aquí tienes mucha información sobre el pinout de los customs, así que paciencia y si no siempre puedes comprar otra.

https://wiki.neogeodev.org/index.php?title=Category:Chips

Un saludo