Autor Tema: Biomechanical Toy (Gaelco) - Problemas gráficos  (Leído 488 veces)

0 Usuarios y 1 Visitante están viendo este tema.

sergiopolog

  • Recien llegado
  • Mensajes: 6
Biomechanical Toy (Gaelco) - Problemas gráficos
« en: 10 de Marzo de 2018, a las 10:08 horas »
Hola chicos!

Recientemente he adquirido un pack de placas jamma y para mi sorpresa cuando me di cuenta que una de ellas era el clásico de Gaelco - Biomechanical Toy!:


Parece que se trata de la revision /2 (con ram encriptada?) y parece original con las pegatinas en las roms de fabrica. Tiene también un pequeño puente entre varios pines del conector jamma, más concretamente entre el pin del botón 3 del P1 y el botón de start. Me pareció extraño pero debía ser una pequeña ñapa que hizo algún operador para utilizar el botón 3 como botón de start, pero desde el foro de UKVac me han confirmado que este puente también venía de fabrica  :o

De todas formas, no me pude contener y conecté la placa al supergun que tengo para pruebas. La placa arranca correctamente y suena bien, pero para mi desgracia  :'( enseguida me di cuenta que había algún tipo de problema con la imagen

 



Aquí dejo un par de pequeños videos en los que se muestra claramente el problema gráfico:

En el primer video se puede observar que aparecen una especie de barras cuando la pantalla resplandece en la animación del título del juego:
https://i.imgur.com/TxZHGdU.mp4

En el segundo video se puede ver el problema más detalladamente durante la demo del juego:
https://i.imgur.com/b7IDevq.mp4

Desde mi desconocimiento, creo que se debe tratar de algún tipo de problema con la salida analógica de video, ya que el problema se da en todas las partes de la imagen: sprites, fondos, marcadores...  y no son glitches específicos en los sprites por ejemplo...

Una imagen más:



Lo primero que he hecho y que se hace rápidamente es leer las dos roms que están en zócalo y no hace falta desoldar, para compararlas con los romsets de mame, y lo que he podido averiguar es no coincide con ninguno de los dos disponibles (biomtoy.zip: Ver. 1.0.1884    y   biomtoya.zip: Ver. 1.0.1885) :o :


Me parece extraño que siendo las roms tan diferentes a las de mame (73% y 60% de similitud) el juego arranque y se vea la pantalla (aunque con erorres gráficos).

Como puedo ver la version de mi placa? Estas roms vienen encriptadas? Puede tratarse de una version no dumpeada?


Aun así me gustaría tener esta placa operativa ya que forma parte de la historia arcade de nuestro país!!!
Cual podría ser el problema? Podéis orientarme en por donde empezar a buscar para averiguar el problema?


Gracias y saludos! ;)