Autor Tema: Placa Final Fight CPS1, problemas al calentarse y a más de 4.85V (SOLUCIONADO)  (Leído 10270 veces)

0 Usuarios y 1 Visitante están viendo este tema.

gamezer0

  • Administrator
  • *****
  • Mensajes: 63
Hace un tiempo me agencié una flamante CPS1 con el juego Final Fight. A pesar de que no fue barata, la placa está mal desde el primer momento, aunque el vendedor lo achacaba a mi máquina...

El problema es el siguiente: Con la placa fría, y a 4.85V (el mínimo que admite mi máquina) el juego va bien, pero a ese voltaje no tiene todo el brillo que debería, se ve muy apagado. Hay que subir hasta casi 5.2 para que se vea al máximo de brillo, y al menos a 5 para que entre dentro de lo normal.

Los problemas empiezan en cuanto subo de los 4.85V o cuando la placa empieza a calentarse (basta con tenerla 5 ó 10 minutos encendida), a partir de entonces empiezan a notarse los siguientes síntomas:

-El mapa de la ciudad de la intro (segundo 10 de este vídeo ) se enciende y se apaga a trompicones en cuanto la placa se calienta o si la subo de 4.85V desde el principio. Y aunque esté fría, creo que nunca la he visto tan fluída como en el vídeo.

-El logo del juego deja de aparecer (final del mismo vídeo ), o aparece al cabo de varios segundos. Esto pasa en cuanto la placa lleva un rato encendida, independientemente del voltaje, aunque empeora mientras mayor sea.

-Con voltajes más altos (5-5.20V), y en cuanto lleva un rato encendida, empiezan a desaparecer los textos del juego (tanto intro como ingame)

-Con voltajes altos (5-5.20V) y tras calentarse, si reinicio, el juego no arranca. Tengo que bajar a 4.85V.

En una partida va todo bien, salvo que a 4.85V se ve algo apagado, y que si subo desaparecen los textos.

Otra cosa que no sé si ayudará es que al encender la máquina, la placa emite un sonido extraño (una especie de "ooiiioooooooooo" xD). No estoy muy seguro, pero me suena haber leído en algún sitio, que cuando la placa detecta algo extraño, hace ruidos al encenderse.

Algo que conviene aclarar es que la estuve mirando con Marcos75 hace algunos meses, y probamos la placa superior de juego en otra base que tenía él, y el problema aparecía igualmente, así que todo parece indicar que el problema está en la placa del juego. Sus sospechas eran referentes a la "cucaracha" del slot 1A. Lo que lleva impreso encima es esto: "PAL16L8BCN 949BZD4" en la primera línea, y "S224B" en la segunda.

¿Alguna idea? Os dejo un par de fotos (una general, y otra en detalla del "sospechoso"):

http://img850.imageshack.us/img850/4981/finalfight1.jpg
http://img835.imageshack.us/img835/6067/finalfight2.jpg


Muchas gracias!!!

Actualización (2/7/12)

Solucionado el problema. He puesto una placa C adquirida a LuisDatasat y ahora todo funciona bien :)
« última modificación: 02 de Julio de 2012, a las 20:21 horas por gamezer0 »

lechuck

  • Visitante
Re: Placa Final Fight CPS1, problemas al calentarse y a más de 4.85V
« Respuesta #1 en: 12 de Junio de 2012, a las 23:34 horas »
Un truco que me enseñó un amigo pinbalero y que me ha funcionado muy bien con problemas de calentamiento es usar un spray de frío sobre los  diferentes integrados. En cuanto enfries uno y se arregle el problema, voila, lo tienes.  Puede ser el propio integrado o una soldadura en mal estado.
« última modificación: 12 de Junio de 2012, a las 23:36 horas por lechuck »

Marcos75

  • Socio
  • ****
  • Mensajes: 3046
  • Arcadero de los 80s
Re: Placa Final Fight CPS1, problemas al calentarse y a más de 4.85V
« Respuesta #2 en: 12 de Junio de 2012, a las 23:39 horas »
Hola gamezer0. Estoy haciendo memoria, pero no me acuerdo de los detalles. Entonces, es seguro que con otra placa A (base) el juego funcionaba perfectamente, ¿verdad?

Bien, en ese caso creo que la principal sospechosa es la placa C, pero la verdad es que no conozco mucho del sistema CPS-1.

Con respecto al integrado de 1A, tenemos buenas noticias. Aunque es una PAL protegida y no se puede leer así como así, el equipo de MAME ya la ha leído, y lo que ha incorporado a la ROM del Final Fight es una imagen lista para grabar en una GAL16V8. Yo ya tengo un programador que es capaz de programarla, y tengo también varias GAL. Así que si un día te apetece pasarte por aquí, grabamos una en un momento y probamos.

Si te viene mal, pásame tu dirección por privado y te la mando por correo.

Así salimos de dudas.

Un saludo.

EDITO: Lo que comenta lechuck lo había leído en otras ocasiones. Me parece una buena idea dado que parece un problema térmico.
« última modificación: 12 de Junio de 2012, a las 23:41 horas por Marcos75 »


gamezer0

  • Administrator
  • *****
  • Mensajes: 63
Re: Placa Final Fight CPS1, problemas al calentarse y a más de 4.85V
« Respuesta #3 en: 12 de Junio de 2012, a las 23:57 horas »
Antes de nada, gracias a los 2!

Un truco que me enseñó un amigo pinbalero y que me ha funcionado muy bien con problemas de calentamiento es usar un spray de frío sobre los  diferentes integrados. En cuanto enfries uno y se arregle el problema, voila, lo tienes.  Puede ser el propio integrado o una soldadura en mal estado.

Es buena idea, ¿sabes dónde venden esos sprays? He buscado en Google y los que me salen son recomendados para deportistas, fisios, etc, ¿son esos?

Hola gamezer0. Estoy haciendo memoria, pero no me acuerdo de los detalles. Entonces, es seguro que con otra placa A (base) el juego funcionaba perfectamente, ¿verdad?

No, con la tuya si no me equivoco el problema era el mismo (igual la memoria me falla, pero estoy casi seguro), por eso imagino que el problema está en la placa del medio (juego) o la pequeñita que tiene encima (no se muy bien para qué es, pero debe ser también algo de juego porque tiene pegatinas de Final Fight)

Si te viene bien, me puedo pasar un día y probamos :D Te mandaré un privado.

lechuck

  • Visitante
Re: Placa Final Fight CPS1, problemas al calentarse y a más de 4.85V
« Respuesta #4 en: 13 de Junio de 2012, a las 01:55 horas »
Yo he utilizado spray limpia contactos de residuo cero, pero es un apaño. Uno de frio seco seria lo mas adecuado, pero no he tenido nunca ninguno

Marcos75

  • Socio
  • ****
  • Mensajes: 3046
  • Arcadero de los 80s
Re: Placa Final Fight CPS1, problemas al calentarse y a más de 4.85V
« Respuesta #5 en: 13 de Junio de 2012, a las 08:54 horas »
No, con la tuya si no me equivoco el problema era el mismo

La verdad es que quería decir eso, aunque dije lo contrario. La edad...  ;)

Un saludo.


luisdatasat

  • Marciano
  • Socio
  • ****
  • Mensajes: 305
    • www.datasat.es
Re: Placa Final Fight CPS1, problemas al calentarse y a más de 4.85V
« Respuesta #6 en: 13 de Junio de 2012, a las 11:47 horas »
Hola.

Creo que la averia puede venir de alguna memoria de programa que falla al calentarse.

¿habeis comprobado las 8 eprom de programa?

Son las memorias 34, 35, 36, 37, 40, 41, 42, y 43

Código: [Seleccionar]
Con voltajes altos (5-5.20V) y tras calentarse, si reinicio, el juego no arranca. Tengo que bajar a 4.85V.
Ese sintoma nos puede servir para localizar el fallo en plan "casero".

Pon la placa a 5V y deja que se caliente hasta que no te arranque al reiniciar.

Para hacer la prueba si es una memoria que falla, tenemos que hacer esta prueba con cada memoria de una en una:

Saca una memoria del zocalo, le levantas un poco el pin 32 que se corresponde con la alimentacion de +5V y la vuelves a poner en el zocalo dejando ese pin fuera.

Coges un diodo rectificador del tipo 1N4007 o similar:



Por el lado que no tiene la raya, lo conectas a +5V y por el lado de la raya al pin 32 de la memoria que has dejado al aire.

De esa manera estaremos alimentando esa memoria a 4,8V , apaga y enciende varias veces la placa para ver si arranca bien.

Si al alimentar una memoria de este modo, ves que el problema del arranque a +5V se soluciona, es esa memoria la que esta fallando.

Los sprays de nieve liquida, son muy utiles tambien para detectar este tipo de fallos.

Los puedes encontrar en cualquier tienda de componentes electronicos.



http://www.lasdosm.com/tasovision_nieve_liquida_aerosol_p_933.php
« última modificación: 14 de Junio de 2012, a las 17:09 horas por luisdatasat »

Marcos75

  • Socio
  • ****
  • Mensajes: 3046
  • Arcadero de los 80s
Re: Placa Final Fight CPS1, problemas al calentarse y a más de 4.85V
« Respuesta #7 en: 13 de Junio de 2012, a las 13:31 horas »
 :o

Lo que vamos a aprender aquí...  :)

Una cosa, Luis. Había leído en alguna ocasión alguien que se había encontrado con fallos en las EPROM asociados a la alimentación, como tú apuntas en este caso.

¿Te has encontrado tú a menudo con este problema?

Gracias.

Un saludo.


ricky2001

  • Moderador 2
  • **
  • Mensajes: 1446
  • Arcade Adicto
Re: Placa Final Fight CPS1, problemas al calentarse y a más de 4.85V
« Respuesta #8 en: 13 de Junio de 2012, a las 16:25 horas »
 :o :o esto si que me interesa, muchas gracias por la info luidatasat, no quiero desviar el post pero aprovecho para hacerte una breve pregunta, sabes tu que puede pasar a esas placas que al contrario que esta hay que sobre alimentarlas o no van bien??, problemas gráficos o que ni arrancan.

Si esto no te parece bien aquí inicio una nueva consulta con placas y sintomas concretos.

Saludos y Gracias, Ricardo

luisdatasat

  • Marciano
  • Socio
  • ****
  • Mensajes: 305
    • www.datasat.es
Re: Placa Final Fight CPS1, problemas al calentarse y a más de 4.85V
« Respuesta #9 en: 13 de Junio de 2012, a las 16:28 horas »
Marcos, cuando no se tienen las herramientas adecuadas hay que agudizar el ingenio.  :D

Problemas asociados a la alimentacion, te los puedes encontrar en cualquier componente, no solo en eprom.


luisdatasat

  • Marciano
  • Socio
  • ****
  • Mensajes: 305
    • www.datasat.es
Re: Placa Final Fight CPS1, problemas al calentarse y a más de 4.85V
« Respuesta #10 en: 13 de Junio de 2012, a las 16:52 horas »
ricky2001

Me imagino que te refieres a placas Bootleg.

La de virguerías que tenia que hacer para dejar las placas funcionando como es debido a 5V, cuando las recibía de los coreanos, ni te cuento....  ::)

Su control de calidad consistía en, si la placa no funciona bien a 5V le bajo o le subo la tensión y si da el pego, ya esta perfecta para vender a los Españoles.  :)

En eso si que no te puedo orientar, se trata basicamente de ir añadiendo condensadores, resistencias y cambiando algun que otro circuito con determinadas marcas, hasta dar con la solucion.

Para muestra un boton de mi "libro rojo"

Apuntes de mi cosecha para solucionar problemas en un modelo de Cadillac bottleg:



Marcos75

  • Socio
  • ****
  • Mensajes: 3046
  • Arcadero de los 80s
Re: Placa Final Fight CPS1, problemas al calentarse y a más de 4.85V
« Respuesta #11 en: 13 de Junio de 2012, a las 16:58 horas »
Esto...... Luis, una cosita....... ¿A quién hay que arrancar las piernas para conseguir tu "libro rojo"?  ::)

¡Qué bueno!


Fistro

  • Recien llegado
  • Mensajes: 45
Re: Placa Final Fight CPS1, problemas al calentarse y a más de 4.85V
« Respuesta #12 en: 13 de Junio de 2012, a las 17:08 horas »
Lo de cambiar el LS por uno de marca hitachi o Gold Star es por jugar con las tolerancias de estos integrados y solucionar asi problemas?? Esto tiene mas mérito que cualquier reparación normal, entiendo que Marcos75 rompa piernas por el manuscrito.
Saludos.

luisdatasat

  • Marciano
  • Socio
  • ****
  • Mensajes: 305
    • www.datasat.es
Re: Placa Final Fight CPS1, problemas al calentarse y a más de 4.85V
« Respuesta #13 en: 13 de Junio de 2012, a las 17:37 horas »
Fistro!!

Me alegra leerte de nuevo por estos mundos.  ;)

Efectivamente, aunque todos los circuitos con igual referencia hacen la misma funcion, siempre hay una pequeña variacion de unos fabricantes a otros que puede afectar a las señales, sobre todo cuando se tratan de datos a alta velocidad.

El "libro rojo" es un incunable que quien sabe, lo mismo algun dia sale a la luz publica, aunque no sea en su totalidad.  ???



manufear

  • Animadillo
  • **
  • Mensajes: 169
Re: Placa Final Fight CPS1, problemas al calentarse y a más de 4.85V
« Respuesta #14 en: 13 de Junio de 2012, a las 20:18 horas »
joder hace una semana tire al container una bootleg malisima de final fight si lo se te la envio a contra reembolso y la desmantelas para arreglar la tuya.

Una pena.